Odoo Help


28 Answers
6/4/13, 8:02 AM

The only thing that will trigger this error is if the admin password you entered is not right. If you are using a custom server config file, check to verify the password you entered is the one the server is expecting to validate.

You might not have access to this config file if you are not the server's administrator.

6/4/13, 10:03 AM

It is possible to run openERP while NOT setting the password in the config file.

6/4/13, 11:47 AM

In which case openerp-server runs with the default admin_passwd which is "admin". You should change this if you're in production. Jessie, did you try the common "admin"?

6/5/13, 4:38 AM

It is even possible to change the default password for admin while NOT adding the new password to the config file. Unless we are speaking about different config-files (I refer to /etc/openerp/openerp-server.conf, on Ubuntu)

6/5/13, 6:16 AM

I doubt that. This is because if you are not using a config file to run the config.py parser will use some default server config options to run. Refer to line 68 of $_OPENERP_DIR/tools.config.py class configmanager(object): def __init__(self, fname=None): # Options not exposed on the command line. Command line options will be added # from optparse's parser. self.options = { 'admin_passwd': 'admin', 'csv_internal_sep': ',', 'login_message': False,}

6/5/13, 6:19 AM

try invoke the server and generate the config file and then change the password from there; then use this generated/modified config file to run your server thereon.

George Appiah
11/27/13, 10:35 AM

"The only thing that will trigger this error is if the admin password you entered is not right."

That's certainly not true, as mine turned out to be a memory allocation issue.

Pouya Malekinejad
7/1/13, 11:38 AM

Check pg_path in your openerp-server.conf, it solved my problem

9/6/13, 10:46 AM

pg_path = C:\Program Files (x86)\OpenERP 7.0-20130904-231132\PostgreSQL\bin

August Doo
10/13/14, 7:38 PM

how come a check can solve the problem? How did you do it?

Pouya Malekinejad
9/30/15, 11:10 AM

well, main was incorrect, I corrected it. Only checking didn't solve my problem of course!

6/4/13, 5:08 PM

I was having the same problem with Internet Explorer. Switched to Firefox and was able backup without any errors.

Kestutis Urbonas
8/29/15, 4:22 PM

I had same problem. Access Denied - when trying to backup using Microsoft Internet explorer or Edge.

Firefox helped me. I made backup successfully.

George Appiah
11/27/13, 10:32 AM

I had this issue on two computers, and on both machines it turned out to be a memory allocation issue.

I was damn sure the master password was correct, as I could use the existing master password to create a new one. When I tailed the log, I saw " CANNOT ALLOCATE MEMORY" whenever I clicked the button to backup the database. On one machine simply rebooting fixed the problem. On the other server I had to assign additional memory to the virtual machine before the backup could be done.

So if anyone is having this issue, definitely take a look at the OpenERP log file for clues as to what may be happening!

1 Comment
Elephante, Sean Samborski
7/15/14, 1:35 AM

I will say this has happened to me a couple of times and I always forget what I did to fix it because of the time between. I know now I just reboot the server and it works fine.

August Doo
10/13/14, 7:37 PM

I have the same problem and I'm pretty sure the pwd is correct, and I did that in Chrome, Firefox, and they both failed. When I tried IE11, it returned "OpenERP Client Erro, Syntax error, host:8069/web/static/src/js/core.js:449", so I guess something must be wrong with one of the files. I have to say this is a serious issue because if you can't backup your database, then the system get a 500 error later, it will cost more time to fix it. 

[update] Now the issue turns to be SOMETIMES it can be backed up, sometimes it can't with the same pwd. If you can't back up, it will also lead to the disconnection of your host. Seems it's a serious issue.

Ad van den Bemt
8/25/13, 2:42 PM

I have a workaround for this problem with IE10 and other browsers. But somehow I'm not allowed to put text looking like "links" in my contribution. So I try this way. If you get the “access denied” popup. Simply copy the “denied” link to the adres box of your browser and the backup download starts. I hope this helps.

Tom De Busscher
6/4/13, 8:26 AM


I have exactly the same problem. I'm sure the password is correct, because when I go to database management -> password, I can change my password without any problem. Where is the location of the config file you're talking about. I'm administrator on the server and in the openERP.

Regards, Tom

6/4/13, 10:04 AM

on Ubuntu, it is at /etc/openerp/openerp-server.conf, on other Linux versions probably same location. On windows, I do not know.

Tom De Busscher
6/4/13, 10:32 AM

Patrick,Thank you for your answer. I'm using a Windows OS and the location of the file is: C:\Program Files (x86)\OpenERP 7.0-20130421-232434\Server\server\openerp-server.conf In the file is indeed a difference between the variables db_password and admin_passwd. I tried both passwords to backup the database, but I keep getting AccessDenied.

6/4/13, 11:50 AM

admin_passwd is the password required to make database operations (create, drop, backup, and restore)

Tom De Busscher
6/10/13, 12:03 PM

I tried both the default password admin and the 2 passwords from the config file, both in IE and Firefox, but I keep on getting AccessDenied. What else can I try ?

6/17/13, 11:19 AM

Try a different browser like chrome but I don't think you have got the right password. Someone might have changed the default admin_passwd. The only way out now is to start and run the server with a different config file which now has the admin_passwd set in there.

6/5/13, 12:37 AM

Hi all,

I am using the default admin_passwd which is "admin" but it comes out with another error "Uncaught TypeError: Cannot read property 'body' of null".

May I know what is the solution for this problem?




6/5/13, 4:40 AM

Sounds like an issue with a module, probably a module you made or downloaded from internet. Do you remember which module(s) you have added/modified lately? Or did you do an update of your openerp installation recently?

6/9/13, 11:35 PM

Hi Patrick, I just installed openerp-allinone-setup-7.0-latest package (windows version) from OepnERP website and I didn't modify any module.

Thierry Godin
8/25/13, 3:05 PM

Backup doesnot work with IE - Try FF or Chrome instead.

5/24/14, 12:43 AM

I have same problem. Password is correct because I can easily Duplicate my DB, but when start Back up:

"2014-05-24 04:23:25,823 1332 ERROR ? openerp.addons.web.http.HttpRequest.dispatch: An error occurred while handling a json request
Traceback (most recent call last):
  File "C:\OpenERP7\OpenERP 7.0-20140422-231307\Server\server\openerp\addons\web\http.py", line 285, in dispatch
TypeError: backup() got an unexpected keyword argument ''
2014-05-24 04:23:25,865 1332 INFO ? werkzeug: - - [24/May/2014 04:23:25] "GET /web/database/backup?token=1400905405768&backup_db=olenka&backup_pwd=admin&=&session_id=ecadd017d3bc40c58f4020f056aa1a53 HTTP/1.1" 500 - "

Help me please.

Jasem Elayeb
10/5/13, 7:34 AM

i've the same problem and couldnt find the right answer from google, but i found that i i couldnt even dump the db using pg_dump and the error was.

-bash-4.1$ pg_dump -f DBNAME-dump DBName pg_dump: server version: 9.2.4; pg_dump version: 8.4.13 pg_dump: aborting because of server version mismatch

and that was because i followed the tutorial to install on Centos 6.4 and for this i had 2 versions of pgsql client installed. i removed the version 8.4.1

yum remove postgresql-8.4.13-1.el6_3.x86_64

and then i copied the pg_dump and pg_dumpall from newer version installed in tutorial

[root@tedt ~]# cp /usr/pgsql-9.2/bin/pg_dump* /usr/bin/

then test cli dump and works fine and web dump works fine too.

i wish this solution works for you too.

Ask a Question
Keep Informed
7 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Odoo Training Center

Access to our eLearning platform and experience all Odoo Apps through learning videos, use cases and quizzes.

Test it now