Odoo Help

0

0
2 Answers
1
Avatar

Niyas Raphy India

--Niyas Raphy--
26418
| 7 7 11
Wayanad, Kerala, India
--Niyas Raphy--

Odoo Techno Functionalist

Feel free to connect :  niyasraphyk@gmail.com

Twitter:https://twitter.com/niyasraphy
LinkedIn: https://www.linkedin.com/in/niyasraphy/
FB:https://www.facebook.com/niyasraphy123
Whatsapp : +917736136763
Happy to help :)

Niyas Raphy India
7/31/17, 10:48 PM

Hi,

Hope you have upgraded the module after editing the template, if not you have to upgrade it. Then you have to make sure that the template is the same. if the template is the same and can't find any changes on printing ,Then

Activate the developer mode, Settings -> Technical -> Reports -> Reports, then select the corresponding template and then check whether , reload from attachment field is ticked, if so just untick it.

Thanks

0
FG Germany
8/30/19, 10:36 AM

odoo saves the content of your xml file in his database. As long as the file isn't written to the database odoo takes the view from the database and NOT from your upgraded xml file.

You can force odoo to write the file to the database by upgrading your module. Make sure that the xml file is listed in the manifest and the xml file doesn't have a noupdate=True tag.

Another way is to start your odoo server with the --dev=all option. With this option odoo does take its qweb information directly from the xml files.

You can also start the server with -u <name of the module the xml is part of / the xml is listed in the manifest>. -u stands for upgrade and upgrades the module you name afterwards after the start of the server.

Ask a Question
Writer
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now