Odoo Help

12

8
26 Answers
16
Avatar

Davide Corio Italy

--Davide Corio--
Davide Corio
1912
| 5 4 9
Bricherasio, Italy
--Davide Corio--

Odoo Evangelist and Consultant

Davide Corio Italy
2/9/13, 2:30 AM

The common problem with v7, is that many people search for modules in the "Apps" list.

Anyway, give Administrator the "Technical Features" permission, then return to Settings > Modules and run "Update modules list".

Then, search for your module under "Installed modules".

Pay attention to the already applied filters on the top right corner of the view.

3 Comments
Camptocamp SA Switzerland
2/9/13, 12:33 PM
john
2/13/13, 6:25 PM

i downloaded the enapps csv tool to windows, unzipped and ftp to /opt/openerp/openerp-7.0-20130122-001415/openerp/addons/ea_import.... set admin to technical then update modules list but ea_import is not listed under installed modules (filter removed and in list view)

Elephante, Sean Samborski United States
12/30/13, 12:10 AM

This is a confusing problem that I learned early on, but really it is easily rectified by OpenERP. It would be too simple to turn off the apps for community modules and for installations with more than 3 users as per their Enterprise permissions. Many apps use the admin panel for installing modules and so users experienced with other software are going to be confused by these limitations.

2
Avatar

Lucio Argentina

--Lucio--

883
| 6 5 9
Buenos Aires, Argentina
--Lucio--
Karma will give me a place in heaven!
Lucio Argentina
2/15/13, 7:29 AM

The addons folder it is not supposed to be the one inside server. At the same level as server there's probably a folder named addons. Place your modules there.

After you log into the system you need to update the module list. Also, as Davide said, you should check for the default filters, in the top right.

If none of the above works, try looking in the server.conf file. In there you can specify the folder where the OpenERP looks for the module (i.e. the addons folders).

1  [options]
2  addons_path = /home/.../addons1,/home/.../addons2
3  ...

As you can see, you can specify more than one folder for the system to look for the modules, separate the absolute path with a comma. To use this configuration file, launch the server with the -c option like:

./openerp-server -c /<path>/server.conf

Hope it helps!

2 Comments
Francisco Luz Brazil
3/25/13, 6:23 PM

Just adding to this answer that you should also go to "Update Module List", click on update and after that go to "Installed Modules", remove the search filter, if any, and search for the module you had added.

Camptocamp SA, Guewen Baconnier Switzerland
4/28/15, 1:46 AM

Regarding this comment "At the same level as server there's probably a folder named addons. Place your modules there.": you should never move modules in the server/addons path, but instead add the additional addons folder in the addons-path.

1
Abdullah A. Kuwait
11/4/17, 9:42 AM

Hello,


I run into this issue myself with Odoo 10 CE.

I was trying to install a theme, so here is the steps to do so:


1- Upload & extract theme files under addons folder (That's /var/lib/odoo/addons/10.0 in CentOS7)

2- Add the right permissions to user 'odoo'.

2- You might want to restart Odoo

2- Go to Odoo Setting, in the right down corner click "Activate debug mode".

3- Now you go back to the apps dashboard.

4- The tricky part is here, remove the applied filter.

5- Search for the addon keyword, in my case `theme`.

Done, hope that's help.

1
Alfonso Spain
2/26/15, 4:38 PM

Solved in my case:  Windows 8.1 with Odoo 8. 

  1. Give Administrator the "Technical Features" permission
  2. Place the module in a folder included in addons_path =   in the archive openerp-server.conf   (the module must be  placed directly in one of those folders!! it doesn´t work if you place a folder full of new modules!).
  3. Stop and initiate the service odoo-server-8.0
  4. Update Module List
  5. The module just appear

I hope it helps

 

 

 

 

1 Comment
Leonid Kurbatov Russian Federation
5/17/15, 3:57 AM

Worked for me! Main reason I think is "Stop and initiate the service odoo"

1
Avatar

Serpent Consulting Services Pvt. Ltd. India

--Serpent Consulting Services Pvt. Ltd.--
Serpent Consulting Services Pvt. Ltd.
http://www.serpentcs.com
4943
| 7 6 10
Gandhinagar, India
--Serpent Consulting Services Pvt. Ltd.--

Serpent Consulting Services Pvt. Ltd. is an Official Odoo Partner, working on Odoo ever since 2007, experience of 11+ years and witnessed the growth of Odoo.

We are a team of 80+ experts on various verticals. Our portfolio of products can be seen at http://www.serpentcs.com and http://www.serpentcs.in

Our Expertise and Services:

  • Odoo Support

  • Odoo Development

  • Odoo Training

  • Odoo Migration

  • Odoo Implementation

  • Odoo Consulting

Our 290+ Apps on Appstore : https://apps.odoo.com/apps/modules/browse?author=Serpent Consulting Services Pvt. Ltd.

Thanks.

Serpent Consulting Services Pvt. Ltd. India
3/18/13, 9:50 AM

Hello,

If your module is at "../server/openerp/addons" then follow the below steps, Step-1) Give access rights to administrator. Step-2) go to Setting-> Update Module List -> Click on Update. Step-3) Now enter your module name in the search panel which is at the top right corner of the view.

hope now you get your module Name. You can install the module by click on the install button.

Thanks, Serpent Consulting Services.

0
kampeons India
10/20/17, 12:25 AM

You can Refer this \link, it may help a lot.
thanks.

0
Rich Caudill United States
2/22/17, 12:26 PM

Did you run this in the cmd box (linux) "systemctl restart odoo"



Also, did you activate developer mode? I think you have to. 

Click on Help drop down menu(where you admin user name is>About>Activate the developer mode

For images, check out the link below. 

http://pulse7.net/openerp/odoo-9-how-to-activate-developer-mode/

0
Bernardo Kyotoku Brazil
2/6/17, 6:01 PM

I don't know since which version but in version 10 you have to "activate the developer mode (with assets)" in settings for the option "Update Module List" to show in the applications tab.

0
test1 Switzerland
5/13/16, 3:46 PM

Hi @ all

I have copied the modules into the add ons folder. But the copied files can't be read. How can i set with putty the correct rights? Can somebody explain that step by step? thanks

0
Richard HENG France
5/12/15, 12:12 PM

Be sure that it is a module and not a package of modules that you put in the /path/to/addons directory. If it is a package, move the modules inside into the addons directory.



0
Erik Wellander Sweden
3/23/13, 10:21 AM

Unable to get this working. :(

Newly installed latest Ubuntu server. Installed openERP from repository as described on download page.

In my /etc/openerp/openerp-server.conf the first value is the addons_path pointing to, addons_path = /usr/lib/pymodules/python2.7/openerp/addons

So first I upload my l10n_xx.zip file to there change ownership and execution mode to what other files look like. (In the documentation for ver. 6.1 it implies that one could just upload the zip-file as is. ? No-Go!

So I unzip the file creating a folder by name "l10n_xx" in the addons directory mentioned above. Change owner and rights.

I run "Update Module List" go to Apps, remove all filters and search but NO, nothing new.

What is ment with " Step-1) Give access rights to administrator."? Where is this done, I tried looking at the Administrator account, but cannot find anything about rights to add modules. Don't I already the rights as an administrator and with Technical Settings enabled?

Kind regards, Erik

0
Erik Wellander Sweden
3/23/13, 10:23 AM

Unable to get this working. :(

Newly installed latest Ubuntu server. Installed openERP from repository as described on download page.

In my /etc/openerp/openerp-server.conf the first value is the addons_path pointing to, addons_path = /usr/lib/pymodules/python2.7/openerp/addons

So first I upload my l10n_xx.zip file to there change ownership and execution mode to what other files look like. (In the documentation for ver. 6.1 it implies that one could just upload the zip-file as is. ? No-Go!

So I unzip the file creating a folder by name "l10n_xx" in the addons directory mentioned above. Change owner and rights.

I run "Update Module List" go to Apps, remove all filters and search but NO, nothing new.

What is ment with " Step-1) Give access rights to administrator."? Where is this done, I tried looking at the Administrator account, but cannot find anything about rights to add modules. Don't I already the rights as an administrator and with Technical Settings enabled?

Kind regards, Erik

4 Comments
Yoshi Tashiro Hong Kong
3/23/13, 11:59 AM

If you are using version 7.0 you may go to "Installed Modules" after processing "Update Modules List". Remove the "Installed" filter and see if you can find your addon module. In my environment I cannot find the newly created addon modules in "Apps". Weird, but it just seems how it is for now.

Erik Wellander Sweden
3/23/13, 1:35 PM

Yes I have tried all that, but no luck here either. :( I'm currently searching my server to find out if there possibly are other configuration files that are not where one would think they would be.

Laoyumi China
4/10/13, 8:38 AM

I tried too to no avail. Does anybody have the solution? Should be a standard documented procedure.

Mats Kjellberg Sweden
7/29/13, 8:20 PM

Has anyone ever found the solution for this, I have today also tried every tip above without any success..

0
Vishal India
10/3/14, 9:46 AM

I tried "../server/openerp/addons" then follow the below steps, Step-1) Give access rights to administrator. Step-2) go to Setting-> Update Module List -> Click on Update. Step-3) Now enter your module name in the search panel which is at the top right corner of the view."

I am installing the module for Odoo V8, but could not install the module as there is no new module in module list. Please help how to install it.

Kind regards

Vishal

 

0
Paulo Pereira Portugal
6/28/13, 6:38 PM

I followed all the instructions, but when installing the module projects is presented to me the following error:

OpenERP Server Error Client Traceback (most recent call last): File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\web\http.py", line 204, in dispatch File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\web\controllers\main.py", line 1125, in call_button File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\web\controllers\main.py", line 1113, in _call_kw File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\web\session.py", line 42, in proxy File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\web\session.py", line 30, in proxy_method File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\web\session.py", line 103, in send

Server Traceback (most recent call last): File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\web\session.py", line 89, in send File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\netsvc.py", line 292, in dispatch_rpc File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\service\web_services.py", line 626, in dispatch File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\osv\osv.py", line 188, in execute_kw File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\osv\osv.py", line 131, in wrapper File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\osv\osv.py", line 197, in execute File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\osv\osv.py", line 185, in execute_cr File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\base\module\module.py", line 424, in button_immediate_install File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server\openerp\addons\base\module\module.py", line 475, in _button_immediate_function File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\pooler.py", line 39, in restart_pool File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\modules\registry.py", line 218, in new File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\modules\loading.py", line 345, in load_modules File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\modules\loading.py", line 256, in load_marked_modules File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\modules\loading.py", line 187, in load_module_graph File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\modules\loading.py", line 74, in <lambda> File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\modules\loading.py", line 118, in _load_data File "C:\Program Files (x86)\OpenERP 7.0-20130601-231036\Server\server.\openerp\tools\convert.py", line 930, in convert_csv_import Exception: <unprintable exception="" object="">

1 Comment
wassim ammane Turkey
1/7/14, 5:37 AM

hi Paulo, i've the same problem when try to install a module , so how did u solve it please ??!!

Ask a Question
Keep Informed
9 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now