Ayuda

0

url_root not https so the sitemap and robots don't have links with https

Avatar
Samo Arko

I've got a problem the werkzeug parameter url_root gets set to http and not https. I've got a proxy server that has handels ssl and then redirects connections to my internal servers on port 80. Odoo 12 websites to one server and Odoo 14 sites to a different server.

Those servers have nginx as a reverse proxy. In odoo .conf the proxy_mode = True.

The nginx server record:

listen  80;
server_name ;
add_header Content-Security-Policy upgrade-insecure-requests;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_redirect off;

location / {
proxy_pass http://odoo;
}

location /longpolling {
proxy_pass http://odoo-lp;
}

What do I have to do that the url_root parameter will be set correct to https://?

Avatar
Descartar