Odoo Hilfe


3 Antworten
Jānis Lettland
08.02.13, 09:44
  1. Try to uncheck access right Portal.

  2. This is a problem with purchase price list. If you dont use purchase price lists, then easiest way to solve the problem is make empty field Company in Purchases / Configuration / Pricelists for Default Purchase Pricelist with administrator privileges. If you cant see this option, then activate it Settings / Configuration / Purchases / check Manage pricelist per suplier -> Apply. After changes you can uncheck this box.

8 Kommentare
Yaroslav Spanien
08.02.13, 10:03

Uncheking access rights to Portal partially worked. The warning still appears but when I click OK, fill the supplier and save, the new supplier is added without errors. Any recommendation?

Yaroslav Spanien
11.02.13, 04:12

Sorry for not answering before, I don't have access to the server from home. Tested first hour today, the field you pointed out was already empty.

Jānis Lettland
11.02.13, 04:23

do you have some company in Default Sales Pricelist?

Yaroslav Spanien
11.02.13, 04:29

Question edited to add needed details.

Jānis Lettland
11.02.13, 05:07

Is the warning for all 3 companies or only for 2 or 1 company?

Yaroslav Spanien
11.02.13, 05:25

For all the 3 companies

Jānis Lettland
11.02.13, 07:54

Sorry, but i dont have any other idea how to help you (i cant to reproduce exactly your problem). Very similar problem is here https://bugs.launchpad.net/openobject-addons/+bug/1073087 only for Partner list. This could be a bug.

Yaroslav Spanien
11.02.13, 09:26

Correct, the link you pointed out seems to be exactly the error I'm experiencing with my enviroment configuration. Nevertheless should check more as on my local enviroment I don't have the error... really weird.

Abner Galeno Jr. Philippinen
08.02.13, 10:36

It could be with multi-company settings, which is still a fuzzy topic for me.

When I first worked with OpenERP7, I immediately enabled/checked the option Manage multiple companies under

Settings Module -> Configuration -> General Settings

then proceeded to work with multiple companies, setting up the parent, and the child companies.

That's where the ..security restriction... error messages showed up. I gave up testing the multi company module/setup, so I don't encounter those errors anymore.

I think it's because I have no idea what company my settings/changes are applied to. Maybe I should have made some users with access to only one company at each given time, and change the settings only when I'm logged as those users.

1 Kommentar
Yaroslav Spanien
08.02.13, 10:49

I have indeed the multi-company option selected, but this is a must for us as we have 4 companies. I have it also on my local development enviroment and I do not have these errors. I'm trying to find the error by comparing both enviroments, but no luck.

Tom Arnst Finnland
08.02.13, 11:03

We have the same thing with no multi-company enabled.

3 Kommentare
Yaroslav Spanien
08.02.13, 11:12

Thanks. But remember that this should be a comment, not an answer. This was posted as an answer, but it does not attempt to answer the question. It should possibly be an edit, a comment, another question, or deleted altogether. Check SO faq's http://stackoverflow.com/questions/how-to-answer

Tom Arnst Finnland
08.02.13, 11:24

Ok I see.. sorry for that.

Yaroslav Spanien
08.02.13, 11:26

No need to sorry, everyone of us someday was also new on these kind of sites and made same mistakes. That is way I pointed out to the StackOverflow faq and how to answer.

Fragen Sie
Keep Informed
6 Verfolger
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now