Odoo Hilfe

1

3
13 Answers
3
Avatar

Ghanshyam Prajapati

--Ghanshyam Prajapati--

1425
| 4 4 10
Pune, Indien
--Ghanshyam Prajapati--
OpenERP Developer
Ghanshyam Prajapati
03.07.13, 07:41

Hi Alex, Try

<field name="limit">150</field>

in your action (XML file).

Try Following,

for example,

<record id="action_your_object_form" model="ir.actions.act_window">
    <field name="name">Your Object Name</field>
    <field name="type">ir.actions.act_window</field>
    <field name="res_model">your.object</field>
    <field name="view_type">form</field>
    <field name="limit">150</field>
    <field name="view_mode">tree,form</field>
</record>

Hope this work for you.

5 Comments
Alex Malone
03.07.13, 07:50

Thanks for the quick response but I don't think this will work. Like I said in the original question, the tree view in question is embedded, meaning that it is a one2many field within a form and the tree view for that one2many field is defined inline.

Ghanshyam Prajapati
03.07.13, 07:55

Go to Settings / Customization / Low Level Objects / Window Actions Select the action you want to change, edit and change the field Limit, for the number of record you want to display.

Alex Malone
03.07.13, 07:58

I've updated the original question to show the code in question. Again, the emphasis here is that this is an embedded tree view, meaning there are no defined actions for it so there is nothing for me to edit.

Ghanshyam Prajapati
03.07.13, 08:00

If you are using OpenERP v7, then GO to Settings / Technical / Windows Actions. Select the action you want to change, edit and change the field Limit, for the number of record you want to display.

Alex Malone
03.07.13, 08:07

I am using v7. However, like I've said, there is no action defined for this view! Therefore there is nothing to edit in the settings area. As a test, I edited all window actions where the destination model matched what I wanted, but it didn't change anything. I will keep searching for a proper code solution but I expect I am going to have to hack the web client so that it accepts an additional arguement on one2many fields that sets the limit.

1
Hardik Shah
21.04.14, 05:22

Refer the link bugs.launchpad.net/openerp-web/+bug/1310486

I have provided a view_form.js patch.

you can add list_options = '{"limit":10}' as O2M field attribute.

1
kaynis
10.09.13, 08:30

A quick fix which shows only 10 items at a time on sales order. Go to settings-->customization-->window actions--> look for the sales order window action and edit/change the Limit from 80 to 10 or to any number you wish to reduce the number of items displayed at a time to. You may have to add this number of items in the .js (C:\Program Files (x86)\OpenERP 6.1-1\server\openerp\addons\web\static\src\js open view_list.js and add to the list bwt line 273 and 278) file of web module as well. That is what I have done to reduce the number of items displayed in tree view of Sales Order. This does not however stop you from creating more that 10 items which i think is what you want. If you locate the window action of module of interest you can apply this same process to it.

0
Alan Luo
09.11.16, 20:51

if changed \addons\web\static\src\js\view_list.js, like add 'limit': 18, on odoo 8.0, the all tree views will change to limited number of 18, even you've setup limited number on action view.

I would ask question again: I only want to change the number of results on this one single view whilst leaving the other views unaffected. Is this functionality possible?

0
Omar OUHARI
29.11.15, 11:31

Hello,

I have the same issu. did you find a solution.

Thanks to informe me if is there any solution.

Regards.

0
Xsias
10.09.13, 08:09

Similar ask here.

Fragen Sie
Writer
Keep Informed
1 Verfolger
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now