Hilfe

0

Desktop notification google chrome not working Odoo 11

Avatar
Rindhauser Michael

Hi, want to use Google Chrome Browser with Odoo 11.
But with this combination the Desktop notifications didnt work.
With Firefox and Odoo i have now problems with the desktop notifications.
Did anyone have the same problem?

1 Comment
Avatar
Discard

Make sure your browser popup blockers is not enabled.

5 Antworten
2
Best Answer

Desktop notifications only work in https with chrome.

1 Comment
Avatar
Discard
Avatar
Rachid
-

even in Firefox?

2
Avatar
Eliah_Shure
Best Answer

Idk about odoo 11 and chrome but with odoo 12 and Firefox you can enable notifications for sites without https:

1. type 'about:config' in the url bar and confirm

2. confirm that you know what you are doing

3. search for the key 'dom.webnotifications.allowinsecure' and duoble click it so its value changes to 'true'

4. your odoo instance can now request notification permission

1 Comment
Avatar
Discard
Avatar
Ayanga
-

Odoo 12 e Firefox working. Thanks Eliah!

0
Best Answer

Hello!

I think I solved it in Chrome:

I first went to chrome://settings/content/popups and I added my website http://xxx.xxx.xxx.xxx

Then I went to chrome://settings/content/notifications and added it again with s https://xxx.xxx.xxx.xxx

and it worked.

Please check it since I am not a computer engineer and all I do is trial and error.
Thank you.

Avatar
Discard
0
Avatar
Tom L
Best Answer

Hello

I'm facing the same issue and running https. My main question is how to re-enable desktop notification for a client? I already tried out many things like delete cookies etc.. no succes.

regards

Tom

Avatar
Discard
0
Avatar
Rindhauser Michael
Best Answer

Yes i already checked this a 100 times.
but the desktop notify is not working.
I only can hear the notification signal and when i am directly on the webif of odoo, there i can see a browser pop up.

but no desktop notificaton.


regards

Michael

Avatar
Discard