Hilfe

0

Change Helo/Ehlo address

Hi Everyone! 

I'm really having trouble setting up my Odoo 8 outgoing email. My email server is Hostgator, my domain is luckyprints.com.ph. 

The problem is, if I send email from Odoo to any of my hotgator emails, everything is sent out ok. If I send out an email to gmail, yaho, etc. The email is never received by the recipient. 

I talked to hostgator about this. Apparently the Helo / Ehlo record of 127.0.0.1 is being blocked by their outgoing spam filters. If I send emails within my domain names (luckyprints.com.ph) the email push through because technically they never leave the server. 

According to hotgator, the Helo / Ehlo record has to be changed. I hope someone can help me do this as I'm only setting this up on my own. Odoo is self hosted on my server within my Synology box. 

Here's the log file for a message that was blocked:

2017-08-23 22:15:58 1dkicf-002U2N-Mw <= admin@luckyprints.com.ph H=([127.0.0.1]) [130.105.207.185]:19238 I=[198.57.247.181]:465 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=no A=dovecot_plain:admin@luckyprints.com.ph S=38099 id=1503543645.970272064208984.512518157576484-openerp-6-sale.order@LPSERVER T="YourCompany Quotation (Ref SO006)" from <admin@luckyprints.com.ph> for luckydog.animation@gmail.com
2017-08-23 22:15:58 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1dkicf-002U2N-Mw
2017-08-23 22:15:58 1dkicf-002U2N-Mw => /dev/null <luckydog.animation@gmail.com> F=<admin@luckyprints.com.ph> R=fightspamHG T=**bypassed** S=0
2017-08-23 22:15:58 1dkicf-002U2N-Mw Completed

Everything in the settings is correct. The click boxes for "receive inbox notifications by email" is set to all messages. 

Thanks in advance for any help!

Best regards.

Avatar
Verwerfen
1 Antwort
0
Avatar
Dan Čermák
Best Answer

I have glanced over the current odoo source code (v10) and they seem to use python's built-in smtplib. According to the documentation, smtplib uses the fully qualified domain name for HELO/EHLO unless you provide it with an alternative (which odoo afaik does not).

So, I would suggest that you try to change the FQDN of your machine to something that resolves to your server (I guess luckyprints.com.ph would be a good choice) and hope that odoo/smtplib picks it up. On most Unix machines you can achieve that by changing the name in /etc/hostname (and sometimes in /etc/hosts, too). But it would be best if you consult the documentation of your distribution for that.

Avatar
Verwerfen