This question has been flagged
2 Odpovědi
298 Zobrazení

Hello, so I'm following the docs documentation now, but I still encounter the same problem as I watches tutorial, I can't figure out why I can't see my custom module I made. 

I don't know if my I make mistake, but i'm following the docs, please explain to me if possible on which part I got wrong, I really appreciate it guys, thank you so much!

This is my main directory. 





models.py

from odoo import fields, models

class RealEstate(models.Model):
_name = 'estate_property'
_description = 'Real Estate Property'

name = fields.Char(string="Name", required=True)
description = fields.Text(string="Description")
postcode = fields.Char(string="Postcode")
date_availability = fields.Date(string="Date")
expected_price = fields.Float(string="Expected Price", required=True)
selling_price = fields.Float(string="Selling Price", required=True)
bedrooms = fields.Integer(string="Bedrooms")
living_area = fields.Integer(string="Living Area")
facades = fields.Integer(string="Facades")
garage = fields.Boolean(string="Garage")
garden = fields.Boolean(string="Garden")
garden_area = fields.Integer(string="Garden Area")
garden_orientation = fields.Selection(
string="Garden Orientation",
selection
=[('north', 'North'), ('east','East'), ('south','South'), ('west','west') ]
)


estate_menus.xml




estate_property_views.xml




This is my __manifest__.py


{
"name": "Estate", # The name that will appear in the App list
"version"
: "16.0", # Version
"application"
: True, # This line says the module is an App, and not a module
"depends"
: ["base"], # dependencies
"data"
: [
'security/ir.model.access.csv',
'views/estate_property_views.xml',
'views/estate_menus.xml'
],
"installable"
: True,
'license'
: 'LGPL-3',
}




This is my ir.model.access.csv

id,name,model_id:id,group_id:id,perm_read,perm_write,perm_create,perm_unlink
estate.access_estate_property,access_estate_property,estate.model_estate_property,base.group_user,1,1,1,1

ADDITION:

This my odoo.conf

[options]
admin_passwd = $pbkdf2-sha512$25000$7N07x/hf670XwvjfG2OMsQ$4bzF6iN4y0uxX3o915LeEAznINV1e8bZMf1c6rkyOX4Q5UfZE5uMYsvQwiY89IIZ2b61izNr3uVqEnbV3b6kxQ
db_host = localhost
db_port = 5432
db_user = admin
db_password = admin
addons_path = addons , customaddons
http_port = 8015




Avatar
Zrušit
Best Answer

Hi,

Please make sure that you have added the custom addons path in your odoo conf file

Also once you restarted the service, please click Update App List menu also in the Apps

thanks

Avatar
Zrušit
Best Answer

Hi,

1)First You need to provide proper addons pathfor eg:-

[options]
admin_passwd = $pbkdf2-sha512$25000$7N07x/hf670XwvjfG2OMsQ$4bzF6iN4y0uxX3o915LeEAznINV1e8bZMf1c6rkyOX4Q5UfZE5uMYsvQwiY89IIZ2b61izNr3uVqEnbV3b6kxQ
db_host = localhost
db_port = 5432
db_user = admin
db_password = admin
addons_path = /home/cybrosys/odoo/addons, /home/cybrosys/odoo/custom_addons
http_port = 8015

2)Use the module name as like :-       

_name ="estate.property"       

use ' . ' instead of ' _ ' .(standard)


3)After that go to settings -> enable developer mode from Developer Tools section


4)Then go to apps -> Update apps List


Hope it helps

Avatar
Zrušit