Community: Inventory and MRP mailing list archives

expert-inventory@mail.odoo.com

Avatar

RE: Manufacturing Raw Materials not scheduling in accordance with requirements

by
Interpod Offsite, Cameron Monks
- 07 سبتمبر, 2017 10:44:46

Hello All,

 

When planning manufacturing orders, we expect that the lead times of raw materials would be taken into consideration when procuring materials, however it seems that it immediately creates RFQ’s for materials whether they’re created tomorrow or next year. We are on v10 online (Odoo 10.saas~14+e).

 

This is obviously unworkable, as it drastically increases the amount of raw materials on hand. It also isn’t an option for us to schedule less into the future, as some of our raw materials have long lead times (2 months +).

 

It also isn’t an option to just leave the RFQ until its required, as it consolidates the requirements for short term with the long term.

 

Finally, the master production schedule doesn’t seem to be an option, as the MPS function doesn’t give us the scheduling control we require for manufacturing schedule

.

 

What are the steps to reproduce issue?

Create new manufactured product (product A)

Add BoM and routing to Product A

Create new part (Product B), assign Buy & Make to Order routes, and add to BoM (add vendor etc to ensure MTO route works)

Create manufacturing orders for Product A, with date_planned_start for 2 months in the future

 

What is the current behavior that you observe?

An RFQ is generated immediately for delivery of raw materials

 

What would be your expected behavior in this case?

The scheduler should wait until raw materials are required before procuring them. We need to schedule manufacturing at least 2 months in advance due to some long lead time items, however this causes all raw materials to be ordered.

 

 

I have tried every combination of routes, procurement rules, and reorder rules I can think of without success. Also Odoo support and partner support cant help. It seems to be by design, however I cant believe that such a fundamental part of MRP would be missing. Hopefully it’s just an issue with the way we're configuring odoo... can anyone help out with either configuration or workarounds?

 

Thanks in advance.

 

Cameron

 

Sent from Mail for Windows 10