Community أرشيف القائمة البريدية

community@mail.odoo.com

الصورة الرمزية

Re: v11 custom website_template issue

بواسطة
GLOBAL CREATIVE CONCEPTS TECH CO LTD (iWesabe)
- 28 أكتوبر, 2017 02:58:03

Check each lines in other blocks.  Then find which block will stop error while commenting.


Thanks & Regards
-------------
Shameem Babu P K
Odoo Technical Consultant
______________________________
GLOBAL CREATIVE CONCEPTS TECH CO LTD
Kingdom of Saudi Arabia
E  : odoo@iwesabe.com
Ph : +966 13 895 6600; Ext:222
Mob: +966 539 079 660
Web: www.iwesabe.com
___________________
On 10/28/2017 09:55 AM, MD Tanzilul Hasan Khan wrote:
Yes, I did. By dots I meant there are other lines of codes.

Regards.


On Oct 28, 2017 at 12:40 PM, <iWesabe> wrote:


Your code has no problem If same error raises after comment.

Did you close </odoo> ?>


Thanks & Regards
-------------
Shameem Babu P K
Odoo Technical Consultant
______________________________
GLOBAL CREATIVE CONCEPTS TECH CO LTD
Kingdom of Saudi Arabia
E  : odoo@iwesabe.com
Ph : +966 13 895 6600; Ext:222
Mob: +966 539 079 660
Web: www.iwesabe.com
___________________
On 10/28/2017 09:21 AM, MD Tanzilul Hasan Khan wrote:
Dear Shameem,

The app is running in v9 and v10 without any problem. In line three I have this simple template:

<?xml version="1.0" encoding="utf-8"?>
<odoo>
<template id="custom_stylesheet" inherit_id="website.assets_frontend" name="Custom">
    <xpath expr="." position="inside">
        <link rel="stylesheet" type="text/css" href='/website_template/static/src/css/page.css'/>
        <link rel="stylesheet" type="text/css" href='/website_template/static/src/css/style.css'/>
    </xpath>
</template>

...

...

Even if I comment out this template, it gives the same Error for next templates. 

So, I believe something in v11 has changed or I need to do something, regardless writing template!

Regards.

On Sat, Oct 28, 2017 at 12:10 PM, iWesabe <odoo@iwesabe.com> wrote:


Dear Tanzilul Hasan,

This is not the issue of v11 and lxml. This means your xml code is not correct.

For instance the below code will raise same error.

<?xml version="1.0" encoding="UTF-8" ?>

<odoo>

    <foo name="ssss"></foo>

</odoo>

So you verify each lines in xml.

Thanks & Regards
-------------
Shameem Babu P K
Odoo Technical Consultant
______________________________
GLOBAL CREATIVE CONCEPTS TECH CO LTD
Kingdom of Saudi Arabia
E  : odoo@iwesabe.com
Ph : +966 13 895 6600; Ext:222
Mob: +966 539 079 660
Web: www.iwesabe.com
___________________
On 10/28/2017 08:50 AM, MD Tanzilul Hasan Khan wrote:
Hello,

I have a custom website_template module. When I try to install the module it gives following error:

AssertionError: Element odoo has extra content: template, line 3

In pycharm log: 
website_template.xml:3:0:ERROR:RELAXNGV:RELAXNG_ERR_EXTRACONTENT: Element odoo has extra content: template

I have checked the template format with v11 website but didn't find any difference. The system is using python 3.5.4 and pip3 installed lxml 3.5.0.

How can I fix this?

Regards,
MD. Tanzilul Hasan Khan.

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe




--
MD. Tanzilul Hasan Khan.

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


المرجع