Odoo Help

0

0
2 Answers
-1
Paulo Matos
8‏/5‏/2019 6:56 ص

Dear all,

For those having the same problem, I have found a solution for Odoo 12 and qweb reports.

I just had to use ".replace(',', '.')"" on the code above, replacing the "," for the ".".

With "replace", we can use anything we need as a thousand separator, like  a space for instance, " " (1 000).

So the final code I have used is:

<t t-esc="'{0:,.0f}'.format(int(line['my_value'])).replace(',', '.')" />

Thank you once again

Best regards

Paulo

1
Lars Aam
8‏/5‏/2019 9:03 ص

Or you find the settings for 1000 separator in the setting for language.


Ask a Question
Writer
Keep Informed
2 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now