Help

0

how to stop auto-posting the journal entries in Odoo 10, I can't find the checkbox Autopost Created Moves?

Avatar
Ahmad Abdelgawad

How do i stop the system "Odoo 10" from posting the journal entries automatically when validating the invoice.

I can't find the option "Autopost Created Moves". What is the alternative for it in odoo 10

الصورة الرمزية
تجاهل
4 الإجابات
0
Avatar
Ahmad Abdelgawad
Best Answer

Hi, @subbarao

I am not trying to stop the creation of the journal entry, i am trying to stop autoposting them. i want them to be created with the status Unposted. this could be done in odoo 10 by unchecking the checkbox "Autopost Created Moves"

الصورة الرمزية
تجاهل
0
Avatar
Ahmad Abdelgawad
Best Answer

Hi, @subbarao

I am not trying to stop the creation of the journal entry, i am trying to stop autoposting them. i want them to be created with the status Unposted. this could be done in odoo 10 by unchecking the checkbox "Autopost Created Moves"

2 التعليقات
الصورة الرمزية
تجاهل
Avatar
subbarao
-

okay then you can get the code from action_move_create function ending,

move.post() just comment it

Avatar
Ahmad Abdelgawad
-

Thank you, Subbarao. that will do it, i believe

0
Avatar
subbarao
Best Answer

Hello

Don't stop creation of journal entries automatically when validating the invoice. It may disturb the work flow.

To stock move creation from invoice check the action_move_create  function.

الصورة الرمزية
تجاهل
0
Avatar
subbarao
Best Answer

Hello

Don't stop creation of journal entries automatically when validating the invoice. It may disturb the work flow.

To stock move creation from invoice check the action_move_create  function.

الصورة الرمزية
تجاهل