Odoo Help

0

0
1 Answer
0
Abdellatif EL MIZEB
5‏/11‏/2018 9:55 ص

Hello,

It may be too late but for the sake of others who have the same problem I have found a solution to bypass.

You can disable the button with Javascript:


        ...
	Formview.include({
            ...
            load_record:function(){
	        ...
		if(/*your condition*/){

                    var $button = self.$buttons.find(".o_form_button_edit");

                    $button.prop("disabled", true);

                }
	    }
	});

 

I hope this helps!

1 Comment
wizardz
6‏/11‏/2018 3:01 ص

Hi, thank you

I will test this soon.

Ask a Question
Writer
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register