Odoo Help

0

0
2 Answers
0
wajih baghdadi
17‏/4‏/2019 2:25 ص

Hi Niyas,

thank you for you quick response,

when I change the rule to inactive, user can see all vehicules of all companies and the same field is also empy in the contract.

when I delete the rule , I have same thing (field vehicule is empty in contract) so the fault is coming from fleet rental management !

--------------

0
Avatar

Niyas Raphy

--Niyas Raphy--
15176
| 7 6 11
Calicut, الهند
--Niyas Raphy--

Odoo Techno Functionalist

Feel free to connect :  niyasraphyk@gmail.com

Twitter:https://twitter.com/niyasraphy
LinkedIn: https://www.linkedin.com/in/niyasraphy/
FB:https://www.facebook.com/niyasraphy123

Happy to help :)

Niyas Raphy
16‏/4‏/2019 9:24 م

Hi,

This is due to the record rule you have added, in th rule we have specified that the user should only see the vehicles of his company. There might not be any vehicles/fleet which belong to users company, that is why we are getting empty many2one field.


To make sure that the record rule is the reason, you can just make the newly added record rule active = false, just open the newly added record rule and untick the active field. And then check whether fleets are shown in the many2one field.


As a solution just create a fleet from current user login and see whether it is listed in the many2one field.


Thanks

Ask a Question
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now